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WHAT IS PUBLISHER? 

 It is the business publishing and marketing materials software. 
 

 It helps you create, design, and publish professional marketing 
and communication materials. 
 

 Users can create materials for print, e-mail, and the Web using 
the same familiar user interface in other programs in the 
Microsoft Office System. 
 

 Some of its features are: 
 Expanded selection of publication designs and publication types to 

help users create polished, professional-looking publications for 
print, Web, and e-mail distribution. 
 

 Enhanced layout and graphics features to give users better control 
over how they design their publications. 
 

 Mail and Catalog Merge Wizard allows users to use information that 
is stored in a data source, such as a spreadsheet, table, or 
database, to create a wide range of publications. 
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WHAT IS PUBLISHER? (CONT.) 

 Web Site builder creates professional-looking Web sites that are 
customized for the user needs. 
 Publisher provides new and enhanced features for creating, editing, 

publishing, and updating Web sites. 
 

 Designs for publications that users can send as e-mail 
messages. 
 Users can create and send a wide variety of attractive, high-impact 

publications in e-mail.  
 

 Improved commercial printing features to make it easier for 
users to get professional output of their publications. 
 

 Enhances the publisher workspace by allowing users to 
complete common tasks such as re-arranging pages, finding 
and replacing text, and enhanced zooming. 



PUBLISHER AND OUTLOOK 4 

CREATING A NEW PUBLICATION 

 It is done easily through the use of 
publication designs. 
 

 A publication design gives users the 
structure for creating brochures, calendars, 
etc. 

 

 To create a publication you must: 

 Publication type 

 Design 

 Enter graphics and text 

 Customize it  
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CREATING A NEW PUBLICATION 

(CONT.) 
 You can use different techniques to make a 

publication: 
1. Select a Publication Design 

 Under Publication Types, there are many categories to 
choose from. 

 

2. Search for a publication design at Microsoft 

 In the Search for Templates text box, you can search 
for a publication on the Microsoft Website. 
 

3. Use a template you created  

 By clicking My Templates, you will see a list of your 
own previously made templates.  They have to be saved 
as Templates 
 

4. Begin from another publication 

 Create a publication by beginning from one you’ve 
already designed. 
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SELECT A PUBLICATION DESIGN 

 Follow these steps: 
1. Under the File tab, click New.  This will display 

different types of publication on the right side. 

 

2. Click on a publication type that you like. This will 
display the outer section of the publication. It gives 
you several options for publications such as: 

 Business Cards 

 Catalogs 

 Resumes 

 Etc.  
 

 



PUBLISHER AND OUTLOOK 7 

PUB: PRACTICE #1 

1. Create a brochure advertising your subject using the 

Modular Informational Brochure style. 
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CREATING A NEW PUBLICATION 
3. In the Page Size section (under Options), select the 

desired page size. 
 The number of panels depends on the publication and 

subtype selected. 
 

 The page size will be adjusted according to the number of 
panels selected. 

 

4. Put a checkmark in the Customer Address 
checkbox, if you want to include the customer address 
(Regardless, the business address will be displayed). 

 

5. In the Form section (under Options), select whether 
the inner section of the brochure will contain forms to 
be filled out, or if they will be merely informational. 
 

6. Click the Create button. This will create your 
publication and then you can start filling out the 
information by double-clicking in a section that has the 
sample text. 
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PUB: PRACTICE #2 

1. Select the page size of 3 panels. 
 

2. Fill out the primary business information for your school including 
school name, phone number, address, fax number, and e-mail 
address. You can use fictitious names, addresses and numbers. 
 

3. Enter the following: 

• Benefits of your subject (its usefulness in real life).  It should be in 
the Main Inside Heading section. 
 

• Main topics to be covered during the semester with their importance 
(reasons why students require that knowledge). It should be in the 
Secondary Heading section. 
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PUB: PRACTICE #2 

 

• Number of hours per week, office hours, and a brief curriculum of 
the teacher in the Back panel Heading section. 
 

• In the Business Name page with the Product/Service Information 
textbox, enter the school name, your subject, any appropriate 
tagline and the school’s phone number (if not previously entered). 

 

4. Save your publication as MySubjectBrochure.  
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REDESIGNING A PUBLICATION 

 In theory, you can change redesign a publication 
when you are well along in a project. 
 

 However, in practice changing these designs can 
have unforeseen consequences. 

 For instance, changing to a new color scheme with the 
current design publication could render the text almost 
invisible. 
 

 The following basic changes can be done to 
redesign a publication: 

 Using a different publication 

 Using a different color scheme 

 Using a different font scheme 

 Using a different [publication] options 
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REDESIGNING A PUBLICATION 

(CONT.) 

 Choosing a different design 

 Refers to the way all the elements in a publication 
are put together. 
 

1. Click the Change Template button in the Page Design 
tab. The Change Template window appears. 
 

2. Click on the desired design. 
 

 Choosing a color scheme 

 Refers to the general way all the your desired 
colors are distributed in the publication. 

 

1. Select the Schemes group in the Page Design tab. 
 

2. Click on the desired color scheme. 
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REDESIGNING A PUBLICATION 

(CONT.) 

 Choosing a font scheme 

 Refers to the all fonts that will be used in the 
publication. 

1. Click Fonts in the Page Design tab, Schemes group. 
 

2. Click on the desired font scheme. 
 

 Choosing a new page size 

 Refers to how large or small the page will be.  
This will have a direct impact on how the 
headings, graphics, and text fit on the page. 

1. Click Size in the Page Design tab, Page Setup group. 
 

2. Click on the desired page size. 
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ZOOMING IN/OUT AND PAGE 

NAVIGATION 
 Zooming in 

 Move the zoom  slider (located at the bottom right) to the 

right towards the plus sign. 
 

 Zooming out 

 Move the zoom  slider (located at the bottom right) to the 

right towards the minus sign. 

 Page Navigation 

 When the publication has several pages,  to move from 

page to page just click on the page slide located on the 

navigation pane (left side of the screen). 
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USING LAYOUT GUIDES 

 There are several guides that can help users 
line up frames, graphics and lines of text. 
 

 Margin guides: 
 Blue lines that show where page margins begin and 

end. 

1. Click on the View tab. 
 

2. Click on Boundaries and also click on Guides. 

 This toggles on/off the margin guides. 

 

 Baseline guides: 
 Horizontal lines to help users aligning frames and 

objects. 

1. Click on the View tab. 
 

2. Click on Baseline. 

 This toggles on/off the baseline guides. 
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USING LAYOUT GUIDES (CONT.) 

 Ruler Guides: 

 It can also help line up frames and objects and can 

be placed anywhere on the page. 

1. Click on the View tab. 
 

2. Click on Rulers. 

 This toggles on/off the ruler guides. 
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FITTING TEXT IN TEXT FRAMES 

 One of the biggest challenges in a 

publication is making text fit in text 

frames.   

 For example, what happens if a headline 

inside a text box is too long to fit? 
 

 Some possible alternatives are: 

 Shrink the text automatically 

 In the Text Box Tools tab, click Text Fit. 

 Click Shrink Text on Overflow. 
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FITTING TEXT IN TEXT FRAMES 

(CONT.) 

 Resizing a Frame 

 Click on the desired frame. 

 Click and drag any of the white circles from the 

corners.  This allows proportionate resizing. 

 Clicking on the left or right circles, resizes the 

frame horizontally.  Clicking on the top or the 

bottom, circles resizes the frame vertically. 
 

 Moving a Frame 

 Click on the desired frame. 

 Move the mouse pointer over any of the borders of 

the frame until the pointer changes to four arrows. 

 Click and drag the frame to a new location. 
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FITTING TEXT IN TEXT FRAMES 

(CONT.) 
 Resizing the Text Frame Margins 

 These margins prevent the text from getting to close to the text 
frame’s border. 

 Right-click the text frame and click Format Text Box. 

 Click the Text Box tab. 

 Change the size of the margins appropriately. 
 

 Making text jump from frame to frame 
 Select the text frame with overflowing text. 

 

 Click the Create Link button on the Text Box Tools tab, 
Linking group. 
 

 Move the pointer over the box that you want the text to flow 
into. 
 

 Click in the target text box to make the text flow there.  The 
text box must be empty for this technique to work. 
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FITTING TEXT IN TEXT FRAMES 

(CONT.) 

 However, if there is little text to fit in a big 
frame, the following can be done besides 
editing the text: 

 Choosing Best Fit 
 In the Text Box Tools tab, click Text Fit. 

 Click Best Fit. 
 

 Inserting Calendar 
 Go to the location where to place the object. 

 On the Insert tab, click Calendars, then click More 
Calendars. 

 Select the desired month and year 

 Click the Insert button. 
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PUB: PRACTICE #3 

1. For the pages that have the Main Inside Heading and Secondary 
Heading sections that experience text overflow, set the text to 
automatically shrink in that situation. 

 

2. In the Back panel heading section, move the picture frame so that its 
top border is at vertical position of 6.5. 
 

3. Resize the textbox below the back panel heading textbox, so that its 
bottom border is at vertical position of 6.0. 
 

4. Change the background color of the previous textbox to a different 
color while it’s maintaining readability. 
 

5. Try and increase the left text margins for the Product/Service textbox 
and observe if the change in appearance is useful for your brochure. 

 

6. If there are any frames that have little text, make the text to have a best 
fit with its frame automatically. 

 

7. Re-save your publication. 
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WRAPPING TEXT AROUND FRAMES 

OR GRAPHICS 

 This can improve the layout of your 

publication. 
 

 The text wrapping can follow the 

contours of a picture/frame or run flush 

with the picture’s frame. 
 Double-click the item that the text is to wrap 

around. 

 In the Picture Tools Format tab, click Wrap Text. 

 Choose a wrapping option on the drop-down list. 
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REPLACING THE PLACEHOLDER 

GRAPHICS 

 Publication designs contain generic clip 
art images and graphics. 
 

 Generic graphics can be replaced (just 
as text) with your own. 

 Right-click the generic picture.  A pop-up 
menu appears. 
 

 Click on Change Picture.  It will open a 
window where you can browse for the 
picture that you want. 
 

 Click Insert when done. 
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PUB: PRACTICE #4 

1. Change the text wrapping for all the pictures on the inside 

of the brochure to Tight. 
 

2. Change all the pictures of your brochure with more 

meaningful pictures (including the logo). 
 

3. Resize and move your pictures as you see fit. 
 

4. Re-Save your publication. 
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INSERTING AND DELETING FRAMES 

ON PAGES 
 Remember that publications are made of frames used 

in text, graphics, tables, Word Art, etc. 
 

 To insert a new frame: 
 Select the desired type of frame (Text Box, Table, Picture, 

Word Art, etc.) by clicking one of them in the Insert tab. 
 

 Go to the area on the publication where it needs to be placed. 
 

 Click and drag the mouse to set a size to the frame (except for 
WordArt, and, Picture). 
 For these exceptions, click on these options and just follow the 

instructions. 
 

 Release the mouse button and follow the instructions. 
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INSERTING AND DELETING FRAMES 

ON PAGES 
 

 To delete a frame: 
 Click the desired frame. 

 Press the Delete key (keyboard). 
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MAKING FRAMES OVERLAP 

 Overlapping frames can create interesting 
effects (e.g. part of a picture can be in front of 
another picture). 
 

 There are three options to try out when 
overlapping frames. 

 Sometimes only one of these options will be required. 

 Other times, more than one combination will be required to 
achieve the desired effect. 

 

 The options are: 
 Text Wrapping: 

 It must be turned off for any frame to overlap. 

 Turn it off by choosing None under the Layout tab of the Format 
[Object] option. 

   
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MAKING FRAMES OVERLAP 
   

 Object and Frame order 
 Tells Publisher which object goes on top of the other. 

 

 double-click on the object. 
 

 In the Arrange group of the [Object] Tools tab, click either 
Bring to Front or Send to Back. 
 

 Fill Color: 
 Sometimes the fill colors from objects at the top can obscure 

other objects. 
 

 

 Right-click on the object and click Format [Object]. 
 

 Remove an object’s fill color by selecting it from the Colors 
and Lines tab and then select No Fill  in the Fill color 
section. 
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INSERTING, REMOVING AND MOVING PAGES 

 Inserting New Page: 
 Click a page navigation button to move to the 

page where you want to insert. 
 

 Click Page on the Insert menu.  The Insert 
page dialog box appears. 
 

 Enter the number of pages to be inserted. 
 

 Decide whether the new pages will be placed 
before or after the current page. 
 

 Decide whether to: 
 Insert a blank page 

 Create one textbox on each page 

 Duplicate all objects on page # 
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INSERTING, REMOVING AND MOVING PAGES 

 Removing a Page: 
 On the Page Navigation pane, click the page to be deleted. 

 Right-click the offending page and then click Delete. If the page 
has content it will warn you before deleting it. 
 

 

 

 Moving a Page: 
 On the navigation pane, just drag the desired page and drop it to 

a new location.  
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PUB: PRACTICE #5 

1. Insert a new picture frame in the Business Name page 

with the Organization Logo.  The picture must be a photo 

of a school. 
 

2. In the Back panel heading section, insert a new picture 

that represents the school teacher’s photo, in the area 

where the teacher’s information is located. 
 

3. Make any necessary adjustments to the previous picture. 
 

4. In the Back panel heading section, remove the picture 

that is at the bottom of the page. 
 

5. Re-save your publication. 
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DROP CAPS 

 A drop cap is a large capital letter that 
drops into the text usually found in the 
first paragraph of an article. 
 

 Follow these steps: 

1. Click the paragraph that is to receive the 
drop cap. 
 

2. Under Text Box Tools Format tab, click 
Drop Cap.  You will see a selection of 
different styles 
 

3. Select the desired drop cap style. 
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BACKGROUNDS FOR PAGES 

 Place colors or gray-shade background 
on the page. 
 

 Make sure to choose a light color or gray 
shade that makes good contrast with the 
text to maintain readability. 

 Click the Page Design tab. 
 

 Click on Background.  The background 
task pane opens. 
 

 Click on a background and/or tint.  It 
applies the background to the current 
page. 
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MASTER PAGE FOR PAGE BACKGROUNDS 

 The master page contains the design and layout 
elements that you want to repeat on multiple 
pages in a publication. 
 

 Using master pages for these common elements 
gives your publication a more consistent 
appearance. 
 

 It also lets you create and update these elements 
in one place, rather than changing them on each 
publication page (company logo). 
 

 Follow these steps: 
 Click the View tab. 

 

 Click on Master Page.   
 

 Insert any new frames or change any page settings. 
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RUNNING THE DESIGN CHECKER 

 The Design Checker will list all of the design 
problems that are detected in your publication, such 
as design elements that are partially off the page, 
overflow text in a story, or a picture that is scaled 
disproportionately. 
 

 In some cases, you will have the option of choosing 
an automatic fix for these problems. 
 

 In other cases, you will have to fix the problem 
manually.  Follow these steps: 

 Click the File tab, and make sure you are on the Info 
section. 
 

 Click on Design Checker.  The Design Checker task 
pane is activated.  It displays the list of items that need 
your attention. 
 

 Fix the problems as you see fit. 
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COMMERCIALLY PRINTING A 

PUBLICATION 
 Sending a publication to a commercial printer is different 

from clicking File and Print. 
 

 Commercial printers either print with process colors 
(CMYK) or spot colors. 

 Process colors are made by mixing Cyan, Magenta, Yellow, and 
Black to make colors. 

 Spot colors are premixed before printing begins. 
 

 Before sending your publication to a commercial printer, 
find out which color system that printer prefers. 
 

 Follow these steps to convert the colors in your publication 
to the color system that the commercial printer prefers: 

 Click the File tab, and make sure you are on the Info section. 
 

 Click Commercial Print Information. 
 

 Click on Color Models.  The Color Printing dialog box 
appears. 
 

 Select the option that suits best your publication. 
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COMMERCIALLY PRINTING A 

PUBLICATION 
 Color Models: 

 Any Color: If you print by using a digital color printer 
(such as a color desktop printer), you use the RGB 
(Red, Green, Blue) color model. When you print a few 
copies, this is the least expensive color model to print. 

 

 Single Color: If you print by using one color, everything 
in your publication is printed as a tint of a single ink, 
which is usually black. This is the least expensive color 
model to print on an offset press. 

 

 Spot Color: If you print by using a spot color, everything 
in your publication is printed as a tint of a single ink — 
usually black — and a tint of one additional color, the 
spot color, which is usually used as an accent. 
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COMMERCIALLY PRINTING A 

PUBLICATION 
 More Color Models: 

 Process colors: your publication is printed in full color 
by combining varying percentages of the process-color 
inks cyan, magenta, yellow, and black. Process-color 
printing always requires setting up the press with the 
four CMYK inks. It also requires skill on the part of the 
press operator to line up the impression of one ink with 
the others, which is called registration. 

 

 Process Plus Spot Colors: This color model is the 
most expensive to print because it combines process-
color printing (four inks) with one or more spot-color 
inks. You use this color model only if you want both full 
color plus a highly saturated or metallic color that can't 
be produced by using CMYK. 
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CONVERTING A PUBLICATION INTO A 

WEB PUBLICATION 
 You can convert a print publication to a Web publication, 

and vice versa. 
 

 Follow these steps: 
 Open the print publication you want to convert to a Web 

publication. 
 

 On the File tab, on the Save & Send section click Publish to 
HTML. 
 

 Select which version you want a single file without additional 
supporting files (MHTML) or the standard webpage (HTML) 
with additional support files. 
 

 Click Publish HTML.  Specify the location of your files and 
click Save. 
 

 NOTE: 
 Before doing the conversion, it is advisable to create 

hyperlinks between pages if your publication has more than 
one in order to navigate within pages when viewing it through 
a Web browser. 
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PUB: PRACTICE #6 

1. Change the background of your pages to the texture named 

Parchment. 
 

2. Create a miniature frame of your logo picture and place it on the top 

of each section of the master page. 
 

3. Run the Design Checker and fix any problems as you see fit. 
 

4. In the Back panel heading section, remove the picture that is at 

the bottom of the page. 
 

5. Save your publication as Web Brochure. 
 

6. Convert your brochure to a Web Publication with a navigation bar 

that would allow users to move back and forth. 
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OUTLOOK 

 It is a personal information manager from 

Microsoft, and is part of the Microsoft Office 

suite. 
 

 Although often used mainly as an e-mail 

application, it also provides features such as 

a calendar, task and contact management, 

note taking, appointments and meetings 

manager.   
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CREATING A CONTACT GROUP 
 A Contact Group is a collection of contacts to 

whom you regularly send messages. 
 

1. In the Home tab Find group, click the Address 
Book button.  The Address Book Contacts window 
appear. 
 

2. Click New Entry on the File menu. 
 

3. Click New Contact Group. 
 

4. Click OK to open the Untitled Distribution List 
window.  The Distribution List form appears. 
 

5. In the Name box, type the name for your Contact 
Group.   
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CREATING A CONTACT GROUP 

 

 

6. Click the Add New button to create a new 
recipient to be added to the contact group. 
 If you have existing contacts, you select from 

Address Book and select the desired contacts to be 
added to the group. 

 If the contact does not exist in your address book, 
then click New Email Contact. 

 

7. Repeat step 6 as many times as needed. 
 

8. Click Save and Close button to close the 
Contact Group form. 
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CREATING A CONTACT GROUP 

Contact 

Group 

name 

Add New button 

Members appear 

here 
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CREATING A CONTACT GROUP 

Current 

contacts 

Click to add contacts 

as members 
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CREATING A CONTACT GROUP 

CONTACT 

GROUP 
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OUT: PRACTICE #1 

1. Create a contact group called NJIT Teachers Group. 
 

2. Make yourself and two other people part of the contact 

group. 
 

3. Make sure you save the group. 
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SENDING A MESSAGE TO A 

CONTACT GROUP 

 Contact groups make it possible to send a 

message to the same group, without having to 

select each contact. 

 Add new members to the group. 
 

 Delete members from the group. 
 

 If you change information about a contact who is a 

part of a contact group… 
 

 …the contact group is updated automatically 
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SENDING A MESSAGE TO A 

DISTRIBUTION LIST (CONT.) 

1. On the toolbar, click the New Mail Message 

button.  An untitled message appears. 
 

2. Click the To icon to get to your contacts’ list. 
 

3. Select your desired distribution list. 
 

4. Click the To-> button. 
 

5. Proceed with the rest of the steps as you 

normally would. 
 

6. Click Send when finished.   
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SENDING A MESSAGE TO A 

DISTRIBUTION LIST (CONT.) 

Distribution list 
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SENDING A MESSAGE TO A 

CONTACT GROUP (CONT.) 

Message is 

addressed to the 

Contact Group 
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MANAGING YOUR  

APPOINTMENTS AND TASKS 

 The Calendar and Tasks in 

Outlook provide a way to manage 

your appointments and tasks. 

 The Calendar is the electronic 

equivalent of your desk calendar. 
 

 A Task is an electronic to-do list is 

easy to maintain and track its 

progress. 
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1. In the Navigation Pane, click the Tasks button.  The 
contents of the task folder are displayed in the default 
To Do List view. 
 

2. On the toolbar, click the New Task button.  The task 
form appears. 
 

3. In the Subject box, type the name of the task. 
 

4. Click the down arrow to the right of the Due Date and 
select the due date. 
 

5. Click the down arrow to the right of the Start Date and 
select the starting date. 
 

6. Click the down arrow to the right of the Priority box 
and select its priority. 
 

CREATING TASKS 



PUBLISHER AND OUTLOOK 54 

7. If Reminder is selected, set its date and time. 
 

8. In the comments area below, you may type more 
information about the task. 
 

9. On the toolbar, click the Recurrence button.  The 
Task Recurrence dialog box appears. 
 

10.In the Recurrence pattern area, select how often 
the task should be done. 
 

11.In the Range of recurrence area, select when 
should the recurrence end (if desired). 
 

12.Click Save and Close. 

CREATING TASKS (CONT.) 
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OUT: PRACTICE #2 

1. Create a task called Review Math Lesson Plan 
 

2. Set the due date to be today’s date at 1:00pm 
 

3. Set the start date to be today’s date at 10:00pm 
 

4. Set the reminder to be five minutes before due date. 
 

5. Save your task. 
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MANAGING YOUR  

APPOINTMENTS AND TASKS 

(CONT.) 

Current view 

options 

New Task 

button 

Active tasks 
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MANAGING YOUR  

APPOINTMENTS AND TASKS 

(CONT.) 

New Task 

Recipient 

Task status 

Task 

Description 
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USING CATEGORIES 

 A category is a keyword or phrase used to tag 

items such as contacts, appointments, tasks, and 

notes. 
 

 Outlook provides a Master Category List 

 Business 

 Personal 

 Phone Calls 

 Hot Contacts 

 Etc. 
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1. Select a message that you want to assign a 
category to. 
 

2. Right-click the message.  A pop-up menu 
appears. 
 

3. Point to Categorize.  Click on a color coded 
category or click All Categories… The 
Color Categories dialog box appears. 
 

4. You can assign an existing category, create 
a new one and rename it. 
 

5. Click OK. 

USING CATEGORIES (CONT.) 
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MANAGING YOUR  

APPOINTMENTS AND MEETINGS 

 An appointment is an activity that does not 
involve inviting other people or scheduling 
resources. 
 

 

 A meeting is an activity in which you invite 
people or reserve resources. 
 

 

 An event is an activity that lasts 24 hours or 
longer. 
 

 

 You can specify the subject of any activity and its 
start and end times. 
 

 Outlook identifies conflicts in scheduled activities 
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1. In the Navigation Pane, click the Calendar icon.  The 
calendar appears, showing today’s schedule. 

 

2. In the Date Navigator, click the date for the 
appointment. 
 

3. Double-click a time slot.  A new appointment form 
appears. 
 

4. In the Subject box, type its purpose and press Tab. 
 

5. In the Location box, type its location. 
 

6. Specify the start and end times of the appointment. 
 

7. If necessary select the Reminder check box to specify 
the time when you want to be reminded. 
 

8. Clear the check box that says All day event. 
 

9. Click the Save and Close button. 
 

SCHEDULING APPOINTMENTS 
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OUT: PRACTICE #3 

1. Schedule an appointment with your physician. 
 

2. Enter a date, time (both start and ending) and location of 

the appointment. 
 

3. Set a reminder for 1 hour before the scheduled time. 
 

4. Save your appointment. 
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MANAGING YOUR 

APPOINTMENTS AND MEETINGS 

Appointment 

New appointment 

button 

Appointment 

reminder TaskPad 

Date Navigator 

Recurring 

Appointment 

Today 
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MANAGING YOUR 

APPOINTMENTS AND MEETINGS 

TaskPad 

Appointment Date Navigator 

Recurring 

Appointment 

Today 

New appointment 

button 
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MANAGING YOUR  

APPOINTMENTS AND MEETINGS 

Assigned 

category 

Show as busy 

in  Calendar 

Color coding 

label options 

Linked contact 
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1. In the Navigation Pane, click the Calendar icon.  The calendar 
appears, showing today’s schedule. 

 

2. In the Date Navigator, click the date for the appointment. 
 

3. Click the New button and then click New Meeting.  The Meeting 
form appears. 
 

4. In the To section, type the email address of the people you want 
to attend the meeting.  Alternatively, you can click the To button 
to select attendees from your contacts. 

 

5. In the drop-down list, click Add from Address Book.  The 
Select Attendees and Resources dialog box appears. 
 

6. Select a contact from the list. 
 

7. Click the Required or Optional button to determine if the 
attended is required to attend or not. 

SCHEDULING MEETINGS 
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8. In the Subject box, type the purpose of the meeting. 
 

9. In the Location box, type the proper location for the meeting. 
 

10. Select the Reminder check box, if necessary. 
 

11. Specify subject for the meeting, location, and additional details. 

 

12. Click the Scheduling button to view free/busy times to help you 
find the best time for the meeting. 
 

13. Use the horizontal scroll bar in the Free/Busy area to view 
attendee availability for the selected date.  This area shows 
whether attendees are free or not. 

 

14. On the toolbar, click the Send button.  The meeting request is 
sent. 
 

15. In the Plan a Meeting button, click the Close button. 

 
 

 
 

SCHEDULING MEETINGS 


