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PODCASTING CONCEPTS  
 RSS 

 Specifies a means of describing news or other Web 
content that is available for "feeding" (distribution) from 
an online publisher to Web users. 
 

 Podcast 
 Media file that is distributed over the Internet using 

syndication feeds, for playback on portable media 
players and personal computers. 
 

 A podcast can be easily created from a digital audio file. 
 

 These files may then be uploaded to digital music or 
multimedia players like the iPod. 
 

 Podcasting 
 Preparation and distribution of audio files using RSS to 

the computers of subscribed users. 
 

 Allows personal computer to automatically download 
audio files onto an mp3 player at any time.  
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PODCASTING CONCEPTS  
 XML (eXtensible Markup Language) 

 Language that can be used on the World Wide Web, to create a tagging scheme 
that allows elements of a document to be marked according to their content rather 
than their format. 
 

 Content Aggregator 
 Individual or organization that gathers Web content (and/or sometimes 

applications) from different online sources for reuse or resale. 
 

 There are two kinds of content aggregators: 
 Those who simply gather material from various sources for their Web sites, and 

 Those who gather and distribute content to suit their customer's needs. 
 The latter process is called syndication, which is the supply of material for reuse and 

integration with other material, often through a paid service subscription. 
 

 ScreamingMedia, Moreover, and iSyndicate are among the increasing number of 
companies offering aggregated content for resale.  
 

 iPOD 
 iPod is a brand of portable media players designed and marketed by Apple and 

launched in 2001. 
 

 The full-sized model stores media on an internal hard drive, while the smaller iPod 
nano and iPod shuffle use flash memory.  
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HOW IS PODCASTING DONE?  
 These basic steps for podcasting are: 

 

1. The podcaster first saves the file as an MP3 and then 
uploads it to the Web site of a service provider. 
 

2. The MP3 file gets its own URL, which is inserted into an 
RSS XML document as an enclosure within an XML tag: 
 

3. Once a podcast has been created, it can be registered with 
content aggregators, such as podcasting.net or 
ipodder.org, for inclusion in podcast directories. 
 

4. People can browse through the categories or subscribe to 
specific podcast RSS feeds which will download to their 
audio players automatically when they next connect. 

 

 Although podcasts are generally audio files created for 
digital music players, the same technology can be used 
to prepare and transmit images, text, and video to any 
capable device.  
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CREATING A MEDIA FILE 

 The first stage in podcasting is creating 

an audio file. 
 

 In order to create own content, users 

require: 

 Software that records audio and saves it 

in MP3 format. 

 Microphone and speakers/headphones. 
 

 This software can either be purchased 

or downloaded as freeware. 
 

 Among all the freeware, Audacity is a 

software to create record audio files and 

save them as MP3s. 
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USING AUDACITY 
 This software can be downloaded from 

http://sourceforge.net/projects/audacity/ 
 

 It supports Linux, Windows (98, XP, Vista), 
MacOS, and BSD operating systems. 
 

 It supports the following audio formats: 
 MP3 

 WAV 

 AIFF 

 Ogg 
 

 Among its features, it includes: 
 Envelope editing 
 

 Mixing 
 

 Built-in effects 
 

 Plug-ins 
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RECORDING AUDIO  

1. Make sure that the microphone is 

connected to the microphone 

computer’s port. 
 

2. Click the record button. 
 

3. Start speaking with the microphone. 
 

4. To finish recording, click the stop 

button. 
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LISTENING TO THE RECORDING  
 Complete Playback: 

 Click the play button.  The recording by 
default plays from the beginning. 
 

 Playback the sound from a specific 
section (different beginning, same 
ending): 
 Move the mouse pointer over a section of 

the graphic that represents the sound file. 
 

 Click on that spot.  A vertical line is drawn to 
show the location where the playback will 
start from. 
 

 Playback of a smaller section (different 
beginning and ending) 
 Move the mouse pointer over a section of 

the graphic that represents the sound file. 
 

 Click and drag the mouse until the desired 
area is shaded.  This is the area that will be 
played back. 
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PRACTICE #1  

1. Run the Audacity software, 
 

2. Record a 20 second brief introductory 
message and mention the main topic that 
will be explained during the week. 

 

3. Listen to the entire playback. 
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SAVING PROJECT FILES  

 It is not mandatory to do so when creating a podcast. 
 

 However, if you want to manage several audio tracks 

separately, then it is a must do. 
 

 Follow these steps: 

1. Click File. 
 

2. Click Save Project As The Save Project As dialog box appears. 
 

3. Type the name for your project file in the File Name dialog box. 
 

4. Click Browse to select a location where to save your project file. 
 

5. Click the Save button. 
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PRACTICE #2 

1. Save your recording as a Project file 
called <Your initials>Introduction. 

 For example, if your name is Jon Smith, then 
your project name would be JSIntroduction. 
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MAGNIFYING A SEGMENT 

 Usually, the sound wave that gets displayed looks relatively 

small and it can make it difficult to locate a specific point in 

the recording. 
 

 In such cases, it is advisable to zoom in the sound wave 

which visually expands it for easy later editing. 
 

 Follow these steps: 

1. Go to the View menu and then click Zoom In.  This expands the 

entire sound wave. 
 

2. Zoom in as many times as necessary. 
 

 Another possibility is to expand only a section of the sound 

wave by clicking Zoom to Selection (same menu). 
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MOVING TO THE START OF THE 

TRACK 

 Make sure that you are at the very beginning of 

the audio track, before playback. 
 

 Follow these steps: 

1. Go to the Edit menu. 
 

2. Click Move Cursor. 
 

3. Click to Start Track. 
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EDITING A RECORDING 

 There are many problems associated with recording that can creep 
into the file such as: background noise, coughing, clearing your 
throat, etc. 
 

 In such cases, it is desirable to eliminate these spots of our 
recording. 
 

 Depending in how it was originally recorded, it is possible to make 
these corrections without having to re-record the troublesome 
segment. 
 

 Follow these steps: 

1. Locate the segment of the recording that needs to be eliminated.  You 
may need to use the zoom in option to help you find it faster. 
 

2. Highlight the desired segment. 
 

 

3. Go to the Edit menu and then click Delete to delete the segment (It will 
not go to the clipboard). 
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PRACTICE #3 

1. Find a segment that you want to delete 
and do so. 
 

2. Re-save your project. 
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EDITING A RECORDING 

 A segment of a recording can be moved, copied 
and pasted to a different section. 
 

 Moving a segment to another location of the track 

 Follow these steps: 

1. Locate the segment of the recording that needs to be moved.  
You may need to use the zoom in option to help you find it 
faster. 
 

2. Highlight the desired segment. 
 

3. Go to the Edit menu and then click Cut to take out the 
segment (It will go to the clipboard). 

4. Click at the location where you want to paste the new 
segment. 

5. Go to the Edit menu and then click Paste. 
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EDITING A RECORDING 

 Copying a segment to another location of the track 

 Follow these steps: 

1. Locate the segment of the recording that needs to be moved.  

You may need to use the zoom in option to help you find it 

faster. 
 

2. Highlight the desired segment. 
 

3. Go to the Edit menu and then click Copy to take out the 

segment (It will go to the clipboard). 

4. Click at the location where you want to paste the new 

segment. 

5. Go to the Edit menu and then click Paste. 
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WHITE NOISE / TONE 

 We can apply “white noise” or tone sounds to 

enhance our podcast. 
 

 Follow these steps: 
1. Locate the segment of the recording that needs to be added 

the effect, or you can add it at the beginning or the end of the 

track.  You may need to use the zoom in option to help you 

find it faster. 
 

2. Highlight the desired segment (if any). 
 

3. Go to the Generate menu and then click White Noise to add 

white noise, or Tone to add a tone sound respectively. 
 

18 PODCASTING I 



PRACTICE #4 

1. Add a 5 seconds white noise segment at 
the beginning of your podcast. 
 

2. Add a 2 seconds tone sound after the 
white noise, but before your recording. 
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ADDING SILENCE 

 Silence can create pauses between audio 
commentary. 
 

 Sometimes we want to add these to create 
“spaces” while discussing two different topics. 
 

 Follow these steps: 
1. Locate the segment of the recording that needs to be 

silenced, or you can add silence at the beginning or the end of 
the track.  You may need to use the zoom in option to help 
you find it faster. 
 

2. Highlight the desired segment (if any). 
 

3. Go to the Generate menu and then click Silence to take out 
the segment. 
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PRACTICE #5 

1. Insert a silent segment at after the tone 
sound, but before your recording. 
 

2. Insert a silent segment after the end of 
the recording. 
 

3. Re-save your project.   
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GET YOUR MUSIC INTO 

AUDACITY 
 Music can be imported into Audacity. 

 

 This could be an audio file like an MP3 that you 

already have on your computer. 
 

 Follow these steps: 

1. Click Project and then click Import Audio. The select 

one or more audio files window appears. 
 

2. Browse until you find the MP3 file that you are looking 

for. 
 

3. Select and open the file. 
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PRACTICE #6 

1. Import the MP3 file located in the class 
wiki. 
 

2. Re-save your project. 
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CREATING A SEPARATE AUDIO 

TRACK 
 You can create your voice track which you do by 

recording it with your microphone on to a new track in 

your Audacity Project. 
 

 As the voice recording will be on a different track from 

the music, it can after recording be edited entirely 

independently of the music. 
 

 By clicking the record button, a new track is generated.  If a 

music or another sound file already exists within the project, 

a new separate track is created. 
 

 You can edit a track without affecting the others.  
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CREATING A SEPARATE AUDIO 

TRACK 
 Audacity has the handy ability to allow you to record your voice 

track while listening to another track. 

 For example if you have background music, you can dream up what to 
say as the mood of the music takes you and have your voice laid 
down in the same place as the music. 

 Follow these steps 
 

1. Click Preferences in the Edit menu.  Import Audio. The select one or 
more audio files window appears. 
 

2. In the Audio I/O tab, click the checkbox Play other tracks while recording 
new one. 
 

3. Record. 
 

 Note: Use tight fitting headphones to record while listening to a 
music track, to avoid your microphone picking up the music 
playback in your voice recording (applies to other audio as well). 
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ADDING SOME EFFECTS 

 Amplifying the Audio 
 If your recording is too low, you might want to amplify the 

output. 

 Follow these steps: 
 

1. Select the track that you want to amplify.  If you don’t want to select 
the entire track, highlight the section of the track that you wish to 
amplify. 
 

2. In the Effect menu, click Amplify.  The amplify window opens. 
 

3. Enter the number of decibels for the amplification, or leave the 
default value. 
 

4. Click OK 
 

 Note: If the sound became distorted, then move the track 
volume slider to the left until it plays back better. 

26 PODCASTING I 



PRACTICE #7 

1. Amplify your recording. 
 

2. Decrease the volume of the music to a 
level which doesn’t interfere with your 
lecture. 
 

3. Re-save your project. 
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ADDING SOME EFFECTS 
 Fading In/Out 

 Fades in or fades out the selection linearly. 
 

 Follow these steps: 
1. Select the segment that you want to fade. 

 

2. In the Effect menu, click Fade In or Fade Out.  The sound wave’s 
segment will be modified accordingly. 
 

 Changing Pitch 
 Increases or Decreases the audio pitch 

 

 Follow these steps: 
1. Select the segment that you want to change its pitch. 

 

2. In the Effect menu, click Change Pitch.  The Change Pitch window 
appears. 
 

3. Select up or down whether you want to increase or decrease the pitch 
respectively. 

4. Select a pitch from a music scale. 

5. Click OK. 
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PRACTICE #8 

1. Do a fade-in effect for the white noise at 
the beginning of the audio track. 
 

2. Do a fade-out effect to the tone section 
before the silence. 
 

3. Adjust the pitch of the audio if you are not 
satisfied with it.  If you don’t like the 
changes, go to Edit, and click Undo. 
 

4. Re-save your project. 
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CREATING AN MP3 FILE  

 The next major step in creating a podcast is to save your 
audio in MP3 format. 

1. Click File. 
 

2. Click Export As MP3… The Save MP3 File As dialog box 
appears. 
 

3. Type the name for your audio file in the File Name dialog box. 
 

4. Click Browse to select a location where to save your audio file. 
 

5. Click the Save button. 

 It will not save the file if the LAME MP3 Encoder is not previously 
installed in your computer. 

 This encoder can be downloaded from here: 

 http://lame.sourceforge.net/download.php 

 Instructions of how to install it can be found here: 

 http://audacity.sourceforge.net/help/faq?s=install&item=lame-mp3 
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CREATING AN MP3 FILE  

6. After clicking the Save button and the encoder is present, 

then the Edit the ID3 tags for the MP3 file dialog box 

appears. 
 

7. Select either ID3v2 (more flexible) or ID3v1 (more 

compatible). 
 

8. Enter the other information as you see fit. 
 

9. Click OK. 
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PRACTICE #9 

1. Save your recording as an MP3 file called 
<Your initials>_Elegant_Introduction. 

 For example, if your name is Jon Smith, then 
your MP3 name would be 
JS_Elegant_Introduction. 
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EXPORTING A SELECTION 

 Sometimes you want to take only a section on an entire 

podcast and save it as a separate file. 
 

 This can be done by exporting the selection as an MP3 file. 
 

 Follow these steps: 

1. Highlight the desired segment. 
 

2. Go to the File menu and then click Export Selection as MP3.  

The Save As MP3 file window appears. 
 

3. Enter a name for the new file. 
 

4. Click Browse to select a location where to save your audio file. 
 

5. Click the Save button. 
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PRACTICE #10 

1. Export only your audio recording as 
<your initials>No_Music_Introduction 
 

2. Re-save your project.   
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PUBLISHING YOUR PODCAST 

 You can post your work on the Internet to make it 

available to a larger audience. 
 

 Once that your MP3 has been exported to your 

hard drive (or any permanent storage unit), upload 

it to your website and create a link for it. 
 

 You can create a simple download link which is 

just the web address of the file e.g. 

http://www.mypodcast.com/podcast.mp3.  
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PUBLISHING YOUR PODCAST 

 On the other hand if you embed your MP3 in 

your webpage using "embed tags" you can 

choose if your MP3 plays in the background or 

if the browser's media plugin appears in the 

webpage, which will give the user an on and 

off button to play the file in the browser. 
 

 You can also choose whether to autoplay the 

file on page load or not, and so on. 
 

 Some knowledge of HTML might be needed. 
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PRACTICE #11 

1. Post your no music introduction clip in the 
class wiki. 
 

2. Create a 5 to 10 minute podcast about a 
particular topic, as a lecture, class review 
for midterm, or anything else you can 
think of.  Save it as a project. 
 

3. Edit it to fix any problems and when you 
are satisfied export it as an MP3. 
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SOME ADVANTAGES OF 

PODCASTING 

 Readers or subscribers to your content can be on the move 

whilst listening to your material, and this can appeal to 

readers with short attention spans, or who simply prefer 

listening rather than reading. 
 

 Can also be fun for you, giving you a break from the constant 

writing that you have to do to maintain a growing demand for 

instant information. 

 Visitors to your site will also have a positive reaction to this 

new type of alternative blogging. 
 

 Can be great for interviews, as the listener can distinguish the 

change in speaker, and can really listen to what they are 

saying, and enjoy a fascinating debate. 
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SOME DISADVANTAGES OF 

PODCASTING 

 Podcasting and ads do not go well together. 

 Unless you can find a way of integrating spoken ads into your 

podcast itself, then you are likely to find that your revenue will 

be less than with textual articles. 

 The problem is that when a person attempts to click on an 

ad, then in most cases the podcast will stop as well. 
 

 Amount of space the MP3 file consumes. 

 Although a few megabytes of space seems minimal… 

 If you produce regular shows… 

 Then you may find that your disk space and your bandwidth 

when people download the podcasts may get used up more 

quickly than with a textual article. 
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