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PODCASTING CONCEPTS

RSS

o Specifies a means of describing news or other Web
content that is available for "feeding" (distribution) from
an online publisher to Web users.

Podcast

o Media file that is distributed over the Internet using
syndication feeds, for playback on portable media
players and personal computers.

o A podcast can be easily created from a digital audio file.

o These files may then be uploaded to digital music or
multimedia players like the iPod.

Podcasting

o Preparation and distribution of audio files using RSS to
the computers of subscribed users.

o Allows personal computer to automatically download
audio files onto an mp3 player at any time.
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PODCASTING CONCEPTS

XML (eXtensible Markup Language)

o Language that can be used on the World Wide Web, to create a tagging scheme
that allows elements of a document to be marked according to their content rather
than their format.

Content Aggregator

o Individual or organization that gathers Web content (and/or sometimes
applications) from different online sources for reuse or resale.

o There are two kinds of content aggregators:
Those who simply gather material from various sources for their Web sites, and

Those who gather and distribute content to suit their customer's needs.

o The latter process is called syndication, which is the supply of material for reuse and
integration with other material, often through a paid service subscription.

o ScreamingMedia, Moreover, and iSyndicate are among the increasing number of
companies offering aggregated content for resale.

IPOD
o iPod is a brand of portable media players designed and marketed by Apple and
launched in 2001.

o The full-sized model stores media on an internal hard drive, while the smaller iPod
nano and iPod shuffle use flash memory.
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HOW IS PODCASTING DONE?

These basic steps for podcasting are:

1. The podcaster first saves the file as an MP3 and then
uploads it to the Web site of a service provider.

2. The MP3 file gets its own URL, which is inserted into an
RSS XML document as an enclosure within an XML tag:

3. Once a podcast has been created, it can be registered with
content aggregators, such as podcasting.net or
ipodder.org, for inclusion in podcast directories.

2. People can browse through the categories or subscribe to
specific podcast RSS feeds which will download to their
audio players automatically when they next connect.

Although podcasts are generally audio files created for
digital music players, the same technology can be used
to prepare and transmit images, text, and video to any
capable device.
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CREATING A MEDIA FILE

The first stage in podcasting is creating
an audio file.

In order to create own content, users

require:

o Software that records audio and saves it
iIn MP3 format.

o Microphone and speakers/headphones.

This software can either be purchased
or downloaded as freeware.

Among all the freeware, Audacity is a
software to create record audio files and
save them as MP3s.
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USING AUDACITY

This software can be downloaded from
http://sourceforge.net/projects/audacity/

It supports Linux, Windows (98, XP, Vista),
MacOS, and BSD operating systems.

It supports the following audio formats:
o MP3
o WAV
o AIFF

o Ogg

Among its features, it includes:
o Envelope editing

o Mixing
o Built-in effects

o Plug-ins
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RECORDING AUDIO

Make sure that the microphone is
connected to the microphone
computer’s port.

Click the record button.

Start speaking with the microphone.

To finish recording, click the stop
button.
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LISTENING TO THE RECORDING

Complete Playback:

o Click the play button. The recording by
default plays from the beginning.

Playback the sound from a specific

section (different beginning, same

ending): .

o Move the mouse pointer over a section of |
the graphic that represents the sound file.

1|.l} 2.0 3.0

o Click on that spot. A vertical line is drawn to |
show the location where the playback will
start from.

Playback of a smaller section (different

beginning and ending)

o Move the mouse pointer over a section of
the graphic that represents the sound file.

o Click and drag the mouse until the desired
area is shaded. This is the area that will be
played back.
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PRACTICE #1

Run the Audacity software,

Record a 20 second brief introductory
message and mention the main topic that
will be explained during the week.

Listen to the entire playback.
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SAVING PROJECT FILES

It is not mandatory to do so when creating a podcast.

However, if you want to manage several audio tracks
separately, then it is a must do.

Follow these steps:
.. Click File.

2. Click Save Project As The Save Project As dialog box appears.

3. Type the name for your project file in the File Name dialog box.
2. Click Browse to select a location where to save your project file.

5. Click the Save button.
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PRACTICE #2

Save your recording as a Project file
called <Your initials>Introduction.

o For example, if your name is Jon Smith, then
your project name would be JSIntroduction.
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MAGNIFYING A SEGMENT |

Usually, the sound wave that gets displayed looks relatively
small and it can make it difficult to locate a specific point Iin
the recording.

In such cases, it Is advisable to zoom in the sound wave
which visually expands it for easy later editing.

Follow these steps:

1. Go to the View menu and then click Zoom In. This expands the
entire sound wave.

2. Zoom in as many times as necessary.

Another possibility is to expand only a section of the sound
wave by clicking Zoom to Selection (same menu).
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MOVING TO THE START OF THE
TRACK

Make sure that you are at the very beginning of
the audio track, before playback.
fr ‘
Follow these steps: r
1. Go to the Edit menu.

> Click Move Cursor.

3. Click to Start Track.
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EDITING A RECORDING 2
QN L

There are many problems associated with recording that can creep
into the file such as: background noise, coughing, clearing your
throat, etc.

In such cases, it is desirable to eliminate these spots of our
recording.

Depending in how it was originally recorded, it is possible to make
these corrections without having to re-record the troublesome
segment.

Follow these steps:

1. Locate the segment of the recording that needs to be eliminated. You
may need to use the zoom in option to help you find it faster.

2. Highlight the desired segment.

3. Go to the Edit menu and then click Delete to delete the segment (It will
not go to the clipboard).
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PRACTICE #3

Find a segment that you want to delete
and do so.

Re-save your project.

PODCASTING 1 15



EDITING A RECORDING T

A segment of a recording can be moved, copied
and pasted to a different section.

Moving a segment to another location of the track

o Follow these steps:

Locate the segment of the recording that needs to be moved.
You may need to use the zoom in option to help you find it
faster.

Highlight the desired segment.

Go to the Edit menu and then click Cut to take out the
segment (It will go to the clipboard).

Click at the location where you want to paste the new
segment.

Go to the Edit menu and then click Paste.
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EDITING A RECORDING

Copying a segment to another location of the track

o Follow these steps:

Locate the segment of the recording that needs to be moved.
You may need to use the zoom in option to help you find it
faster.

Highlight the desired segment.

Go to the Edit menu and then click Copy to take out the
segment (It will go to the clipboard).

Click at the location where you want to paste the new
segment.

Go to the Edit menu and then click Paste.
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WHITE NOISE / TONE -

We can apply “white noise” or tone sounds to
enhance our podcast.

Follow these steps:

Locate the segment of the recording that needs to be added
the effect, or you can add it at the beginning or the end of the
track. You may need to use the zoom in option to help you
find it faster.

Highlight the desired segment (if any).

Go to the Generate menu and then click White Noise to add
white noise, or Tone to add a tone sound respectively.
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PRACTICE #4

Add a 5 seconds white noise segment at
the beginning of your podcast.

Add a 2 seconds tone sound after the
white noise, but before your recording.
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ADDING SILENCE \55

Silence can create pauses between audio
commentary.

Sometimes we want to add these to create
“spaces” while discussing two different topics.

Follow these steps:

Locate the segment of the recording that needs to be
silenced, or you can add silence at the beginning or the end of
the track. You may need to use the zoom in option to help
you find it faster.

Highlight the desired segment (if any).

Go to the Generate menu and then click Silence to take out
the segment.
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PRACTICE #5

Insert a silent segment at after the tone
sound, but before your recording.

Insert a silent segment after the end of
the recording.

Re-save your project.
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GET YOUR MUSIC INTO
AUDACITY

Music can be imported into Audacity.

This could be an audio file like an MP3 that you
already have on your computer.

Follow these steps:

Click Project and then click Import Audio. The select
one or more audio files window appears.

Browse until you find the MP3 file that you are looking
for.

Select and open the file.
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PRACTICE #6

Import the MP3 file located in the class
wiki.

Re-save your project.

PODCASTING 1 23



CREATING A SEPARATE AUDIO
TRACK

You can create your voice track which you do by
recording it with your microphone on to a new track in
your Audacity Project.

As the voice recording will be on a different track from
the music, it can after recording be edited entirely
iIndependently of the music.

By clicking the record button, a new track is generated. If a
music or another sound file already exists within the project,
a new separate track is created.

You can edit a track without affecting the others.
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CREATING A SEPARATE AUDIO
TRACK

Audacity has the handy ability to allow you to record your voice
track while listening to another track.

o For example if you have background music, you can dream up what to
say as the mood of the music takes you and have your voice laid
down in the same place as the music.

Follow these steps

Click Preferences in the Edit menu. Import Audio. The select one or
more audio files window appears.

In the Audio 1I/O tab, click the checkbox Play other tracks while recording
new one.

Record.

Note: Use tight fitting headphones to record while listening to a
music track, to avoid your microphone picking up the music
playback in your voice recording (applies to other audio as well).
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ADDING SOME EFFECTS

Amplifying the Audio
o If your recording is too low, you might want to amplify the
output.

o Follow these steps:

Select the track that you want to amplify. If you don’t want to select
the entire track, highlight the section of the track that you wish to

amplify.
In the Effect menu, click Amplify. The amplify window opens.

Enter the number of decibels for the amplification, or leave the
default value.

Click OK

o Note: If the sound became distorted, then move the track
volume slider to the left until it plays back better.
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PRACTICE #7

Amplify your recording.

Decrease the volume of the music to a

level which doesn’t interfere with your
lecture.

Re-save your project.
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ADDING SOME EFFECTS

Fading In/Out
o Fades in or fades out the selection linearly.

o Follow these steps:
Select the segment that you want to fade.

In the Effect menu, click Fade In or Fade Out. The sound wave’s
segment will be modified accordingly.

Changing Pitch
o Increases or Decreases the audio pitch

o Follow these steps:
Select the segment that you want to change its pitch.

In the Effect menu, click Change Pitch. The Change Pitch window
appears.

Select up or down whether you want to increase or decrease the pitch
respectively.

Select a pitch from a music scale.
Click OK.
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PRACTICE #8

Do a fade-in effect for the white noise at
the beginning of the audio track.

Do a fade-out effect to the tone section
before the silence.

Adjust the pitch of the audio if you are not
satisfied with it. If you don’t like the
changes, go to Edit, and click Undo.

Re-save your project.
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CREATING AN MP3 FILE 450,
o4

&

|

The next major step in creating a podcast is to save your
audio in MP3 format.

1. Click File.
2. Click Export As MP3... The Save MP3 File As dialog box
appears.

3. Type the name for your audio file in the File Name dialog box.
2. Click Browse to select a location where to save your audio file.

5. Click the Save button.

It will not save the file if the LAME MP3 Encoder is not previously
installed in your computer.

This encoder can be downloaded from here:

o http://lame.sourceforge.net/download.php

Instructions of how to install it can be found here:

o http://audacity.sourceforge.net/help/faq?s=install&item=lame-mp3
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CREATING AN MP3 FILE (%;
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6. After clicking the Save button and the encoder is present,
then the Edit the ID3 tags for the MP3 file dialog box

appears.

7. Select either ID3v2 (more flexible) or ID3vl (more
compatible).

s. Enter the other information as you see fit.

o Click OK.

PODCASTING 1

31



PRACTICE #9

Save your recording as an MP3 file called
<Your initials>_Elegant_Introduction.

o For example, if your name is Jon Smith, then
your MP3 name would be
JS Elegant_Introduction.
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EXPORTING A SELECTION

Sometimes you want to take only a section on an entire
podcast and save it as a separate file.

This can be done by exporting the selection as an MP3 file.

Follow these steps:
1. Highlight the desired segment.

2. Go to the File menu and then click Export Selection as MP3.
The Save As MP3 file window appears.

3. Enter a name for the new file.
2. Click Browse to select a location where to save your audio file.

5. Click the Save button.
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PRACTICE #10

Export only your audio recording as
<your initials>No_Music_Introduction

Re-save your project.
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PUBLISHING YOUR PODCAST

= You can post your work on the Internet to make it
available to a larger audience.

= Once that your MP3 has been exported to your
hard drive (or any permanent storage unit), upload
It to your website and create a link for it.

= You can create a simple download link which is
just the web address of the file e.qg.
http://www.mypodcast.com/podcast.mp3.
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PUBLISHING YOUR PODCAST

On the other hand if you embed your MP3 In
your webpage using "embed tags" you can
choose if your MP3 plays in the background or
If the browser's media plugin appears in the
webpage, which will give the user an on and
off button to play the file in the browser.

You can also choose whether to autoplay the
file on page load or not, and so on.

Some knowledge of HTML might be needed.
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PRACTICE #11

Post your no music introduction clip in the
class wiki.

Create a 5 to 10 minute podcast about a
particular topic, as a lecture, class review
for midterm, or anything else you can
think of. Save it as a project.

Edit it to fix any problems and when you
are satisfied export it as an MP3.
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SOME ADVANTAGES OF
PODCASTING

Readers or subscribers to your content can be on the move
whilst listening to your material, and this can appeal to
readers with short attention spans, or who simply prefer
listening rather than reading.

Can also be fun for you, giving you a break from the constant
writing that you have to do to maintain a growing demand for
Instant information.

Visitors to your site will also have a positive reaction to this
new type of alternative blogging.

Can be great for interviews, as the listener can distinguish the
change Iin speaker, and can really listen to what they are
saying, and enjoy a fascinating debate.
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SOME DISADVANTAGES OF
PODCASTING

Podcasting and ads do not go well together.

Q

Q

Unless you can find a way of integrating spoken ads into your
podcast itself, then you are likely to find that your revenue will
be less than with textual articles.

The problem is that when a person attempts to click on an
ad, then in most cases the podcast will stop as well.

Amount of space the MP3 file consumes.

Q

Q

Q

Although a few megabytes of space seems minimal...
If you produce regular shows...

Then you may find that your disk space and your bandwidth
when people download the podcasts may get used up more
quickly than with a textual article.
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