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WEB PAGE AUTHORING 
 Alternatively, you can use tools that will let you create quicker Web 

pages for your Web site in a matter of minutes. 
 

 These tools are: 
 Conversion Tools 
 Online Web Authoring tools 
 Web authoring software 

 
 

 Conversion Tool 
 Is a feature included in many application software that can convert, for 

example, a Word document into a Web page. 
 

 Online Web Authoring Tools 
 Are provided by ISP or other online companies that host Web pages for 

businesses or individuals. 
 

 By just typing, selecting, dragging and dropping elements, Web pages can be 
created easily. 
 

 These tools are not installed in a user’s personal computer. 
 

 Nevertheless, they lack more advanced features. 
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WEB PAGE AUTHORING 
 

 Web Authoring Software 
 Software that can be installed in a user’s personal 

computer. 
 

 Provide tools specifically designed to create and format 
Web page text, graphics, and links. 
 

 They may contain more advanced features such as 
adding animation, tables, checking links, and such. 
 

 Popular Web authoring software titles that can be 
purchased include: 
 Microsoft FrontPage 
 Dreamweaver 
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WEB PAGE AUTHORING 
 

 Example: 
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USING MICROSOFT EXPRESSION WEB 
 Microsoft Expression Web is a web authoring software 

that allows you to create sophisticated web sites in a 
WYSIWYG environment. 
 

 This means that you can lay out a web page in 
Expression Web just as it will appear in a browser. 
 

 It is easy to use for simple web pages, yet it also has 
great depth, allowing you to interface with databases 
and include multimedia. 

 



CREATING A NEW WEBSITE FROM 
A TEMPLATE 
 Templates are a good place to begin if you require to 

put together a web site quickly. 
 

 Follow these steps: 
1. Click Site-> New Site 

2. Click Templates and select a template from the list. 

3. Click Browse to select a location for your website.  You 
can create any folders that you may need for the main 
site location. 

4. Click Open. Type a name for your site.  

5. Click OK.  This will generate many files needed by 
your website. 
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PRACTICE #1 
 Create a Web site from the template called 

Organization 5.  This website should be created on a 
folder called FirstWebsite under your flash drive. 
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ORGANIZING WEB SITE PAGES 
 After creating a site based on a template, you should 

organize the pages by 

 Creating new pages 

 Organizing folder locations and properties of existing 
pages 

 Deleting pages not needed 
 

 To change properties of existing pages, simply right 
click on the desired page and click Properties.  Make 
the necessary changes. 
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ORGANIZING WEB SITE PAGES 
 

 To create a new page, follow these steps: 
1. In the Folder List, click the root folder. 

 

2. On the toolbar, click the New Document arrow, and then click 
Folder. 
 

3. Type a name for the folder and press ENTER. 
 

4. On the toolbar, click the New Document arrow, and then click 
Page. 
 

5. Click Save on the toolbar.  The Save As dialog appears. 
 

6. Give it a file name. 
 

7. Click the Change Title button and give it a title that will show up 
in the browser’s title bar.  Then click Save. 
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IMPORTING FILES 
 

 Follow these steps: 

1. In the Folder List, select a folder where you want to 
put the file(s).  If it does not exist, create it.   
 

2. On the File menu, point to Import and then click 
File. 
 

3. Click Add File.  The Add File to Import List dialog 
box appears. 
 

4. Select the files and then click Open. 
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ATTACHING THE DYNAMIC WEB 
TEMPLATE 

 

 The Dynamic Web Template enable you to place all the things 
that will stay the same across pages into a template (e.g. logos, 
navigation, etc.) 

1. On the Format menu, point to Dynamic Web Template, and 
then click Attach Dynamic Web Template. 
 

2. In the Attach Dynamic Web Template dialog box, browse to the 
site’s master.dwt and select it.  
 

3. Click Open to close the dialog box and attach the template to the 
new page. 
 

4. Click OK in the Update Confirmation message box.  Your new 
page has  now the correct template applied to and is identical in 
style and layout to all other pages. 
 

5. Click Save. 
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PRACTICE #2 
1. Change the Title property for the page about.htm to 

About: Site Name 
 

2. Change the Title property for the page contact.htm to 
Contact Us: Site Name 

 

3. Change the Title property for the page news.htm to 
News: Site Name 

 

4. Import the html file that has the CV you worked on 
before.  Make sure that before you do, create the folder 
that will hold this file. 

 

5. Attach the master.dwt file to your curriculum vitae.  
Accept everything. 
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ENTERING TEXT 
 Pages in Expression Web have two types of areas: editable 

(I-beam cursor) and non-editable (do not symbol cursor). 
 

 You must go to an editable area, click it and start typing 
normally. 
 

 It is a WYSIWYG editor, so anything that you want to do, 
will (probably) appear as you desire. 
 

 You can do editing functions as in word processing 
software (e.g. cut, copy, paste, etc…) 
 

 Remember to click the Save button (or go to File, Save) 
after entering new text. 
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PRACTICE #3 
1. In about.htm, type information about your 

organization. 
 

2. In contact.htm, replace the default information with 
your own. 

 

3. In information_links.htm, type the following: 
 This section has compiled a collection of useful links.  It 

will be constantly updated as time progresses.  Please report 
any broken links to abc123@xyz.com. 
 

4. Do not type links yet, you will get to it later. 
 

5. Save all your files you added information. 
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WORKING WITH FONTS 
 Using the formatting toolbar you can do basic font options 

such as: bold, italics, underscore, font color, font size, etc. 
 

 Just select the desired text and click the corresponding icon 
from the toolbar. 
 

 It is a WYSIWYG editor, so anything that you want to do, 
will (probably) appear as you desire. 
 

 You can do editing functions as in word processing 
software (e.g. cut, copy, paste, etc…) 
 

 Remember to click the Save button (or go to File, Save) 
when done. 
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PRACTICE #4 
1. In about.htm, from the text typed from the previous 

exercise, put the name of your institution in bold 
and maroon. 

 

2. In contact.htm, put your name in italics 
 

3. In information_links.htm, make the text “broken 
links” as bold and blue. 
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CHANGING CHARACTER SPACING 
 Expression web makes it easy to change the amount of blank 

space between letters or characters. 
 

 Follow these steps: 
 

1. In the Format menu, click Font.  The Font dialog box appears. 
 

2. Click the Character Spacing tab, to make the options visible. 
 

3. From the Spacing list box, choose Expanded or Condensed. 
 

4. Enter the number of pixels by which the text will be expanded or 
condensed. 
 

5. Click Apply to preview the change or click OK to accept the 
change. 
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PRACTICE #5 
1. In about.htm, expand the previously typed text by 1 

point.   
 

2. In information_links.htm, condense by 1 the 
previously typed text. 
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ADDING BORDERS 
 Expression web makes it easy to use borders. 

 

 Follow these steps: 
 

1. In the Format menu, click Borders and Shading.  
The Borders and Shading dialog box appears. 

 

2. In the Setting area of the dialog box, click the option 
that corresponds to the border type you want. 

 

3. In the Style box, click the name or the desired border 
style. 
 

4. Choose a border color from the Color list box. 
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ADDING BORDERS 
5. Enter a border width (in pixels) in the Width box. 

 

6. To turn on/off individual borders, in the Preview 
area, click the button that corresponds to the border 
you want to change. 
 

7. To add empty space between paragraph text and its 
surrounding border, enter pixel values in boxes in the 
Padding area of the dialog box. 
 

8. Click OK. 
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PRACTICE #6 
1. In contact.htm, put a border around the paragraph 

that contains your name.  The left and right border 
should be invisible.  Its style should be ridge.   
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CREATING UNORDERED LISTS 
 These lists use bullets to denote each item. 

 

 Follow these steps: 
 

1. Place the cursor in the page where you want the list to begin. 
 

2. Click Bullets button.  A bullet appears at the beginning of the first line. 
 

3. Type the first item and press ENTER.  You will see the bullet appear on the 
next line. 

 

4. Repeat step 3 as many times as needed. 
 

5. To finish adding items, press ENTER twice. 
 

 Alternatively, if you have already entered items, but they do not appear either 
as a numbered lists or as bulleted items, you may select them and then click 
the Bullets button.  However, each item must be in a separate paragraph 
element (<p> item #1 </p>) 
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PRACTICE #7 
1. In JoeFridayCV.htm, convert the items of the table 

of contents into a unordered list (bullets).   
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LINKING TO AN E-MAIL ADDRESS 
 The quickest way to help your visitors get in touch with you is to include a link 

to your e-mail address. 
 

 For this link to work, the visitor’s browser must either have a built-in e-mail 
component or e able to hook up with the visitor’s e-mail program. 
 

 Follow these steps: 
 

1. Select the text that you want to make an e-mail link. 
 

2. Click the Insert Hyperlink button.  The Insert Hyperlink button appears.  
 

3. In the dialog’s box Link To section, click the E-mail address icon. 
 

4. In the e-mail address text box, type an e-mail address.  Optionally, you may type a 
subject line for the e-mail message generated by this link.  Not all e-mail programs 
and browsers use this subject heading though. 
 

5. Click OK. 
 

 Alternatively, if you do not have text to select, but typing an email address for 
the first time and press either the space bar or ENTER and it will be 
automatically transformed. 
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PRACTICE #7 
1. In links.htm, make the email address already there 

into an e-mail link. 
 

2. Add your e-mail address in contact.htm.   
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LINKING TO A WEB PAGE OR FILE 
 Usually when you create a hyperlink, you already have the link’s 

destination in mind. 
 

 Follow these steps: 

1. Select the text that you want to make a hyperlink. 
 

2. Click the Insert Hyperlink button.  The Insert Hyperlink button 
appears.  

 

3. In the dialog’s box Link To section, click the Existing File or Web Page 
icon. 

 

4. Depending on the location of the page or file, specify the link 
destination: 

 If the destination file is part of the open Web site, in the dialog box file list, 
click the file. 

 If the destination file is located on the World Wide Web, type its URL address 
in the address box 

 

5. Click the ScreenTip button to display text when you move the mouse over 
the link (0ptional).  Type the desired content and click OK. 
 

6. Click OK. 

26 



PRACTICE #8 
1. In links.htm, replace the links generated by the template with the 

following: 
 Microsoft 

 URL-> http://www.microsoft.com 
 Text to display: Microsoft 
 ScreenTip: Click here to go to Microsoft.com 

 

 Wikipedia 
 URL-> http://wikipedia.org 
 Text to display: Wikipedia 
 ScreenTip: Click here to go to Wikipedia.org 

 

 YouTube 
 URL-> http://www.youtube.com 
 Text to display: YouTube 
 ScreenTip: Click here to go to YouTube.com 

 

2. Replace the gibberish text of each site, with a meaningful description 
of each website.  
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VERIFYING HYPERLINKS 
 It involves locating broken internal links and verifying 

external links to make sure that they work. 
 

 Follow these steps: 
 

1. Make sure you have an active Internet connection. 
 

2. Click the Site View tab if necessary, then click the 
Reports View button (bottom of this tab).  

 

3. Click Unverified hyperlinks link.  Expression Web 
switches from Design view to Hyperlinks report in 
Reports view. 
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PRACTICE #9 
 Verify your links. 
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INSERTING A PICTURE FILE 
 Using pictures makes your site more attractive and visually engaging. 

 

 There are different ways of using pictures: 
 You may have a collection of files that you want to use in your web site. 
 You may have pictures from another application or location. 

 

 If you have a group of graphic files that you want to use, follow these steps: 
 

1. Import all the graphic files into a corresponding folder, such as images (see 
slide 6).   
 

2. Open the page where you want to put the picture, and place the cursor where 
you want the picture to appear. 

 

3. Go to the Folder List and open the images folder (or whatever folder that 
contains your image files). 

 

4. Drag and drop the desired image onto the page.  The Accessibility Property 
window appears. 
 

5. Type the Alternate Text.  This is the text that will be displayed as an alternative 
to the picture. 
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PRACTICE #10 
 Insert the picture of Joe Friday as the first thing that 

should appear in the editable area of 
JoeFridayCV.htm. 
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INSERTING A PICTURE FROM A WEBSITE 
 Follow these steps: 

 

1. Right-click on the desired picture and click Copy Image.  This puts 
the image on the clipboard.   
 

2. Open the web page in Expression web where you want to put the 
picture, and place the cursor where you want the picture to appear. 

 

3. Go to the Edit menu and click Paste. 
 

4. Save the page.  The Save Embedded Files dialog box appears. 
 

5. Click the Change Folder button and select the images folder (or 
the folder where you save your pictures). 
 

6. Click OK. 
 

7. Rename the file if you desire (optional). 
 

8. Click OK. 
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RESIZING PICTURES 
 Follow these steps: 

 

1. On your web page, double-click the picture that needs 
to be resized.  The Picture Property dialog box appears. 
 

2. Click the Appearance tab. 
 

3. Select the Specify Size checkbox and then type new 
numbers in the Width and Height text boxes. 
 

4. Click OK. 
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PRACTICE #11 
1. In the photo_gallery.htm file, type over the text that 

says insert your photo gallery here, with The 
following are some remarkable pictures I’ve 
encountered and want to share with everyone.  You 
may apply any font effect that you wish. 
 

2. Go to the WWW and locate at least five pictures that you 
would want to include in your organization’s photo 
gallery. 
 

3. Resize the dimensions of your pictures to have height no 
larger than 500 pixels.  Let the width adjust itself 
accordingly. 
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USING THUMBNAILS 
 Usually, when adding pictures to a web page, the load time 

of the page increases.  The bigger the picture, the more time 
it takes.  What do you do if you have several? 
 

 Thankfully, thumbnails can help address this situation. 
 

 It is a tiny version of the picture you want to display on the 
page. 
 

 The thumbnail is hyperlinked to the full-size picture; so a 
user that wants to see the picture’s original size, needs only 
to click its thumbnail. 
 

 Just right-click the picture on the web page that you want to 
make a thumbnail and click Auto Thumbnail and save your 
page. 
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PRACTICE #12 
1. Create a thumbnail of all your pictures in the gallery. 
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ALIGNING A PICTURE WITH SURROUNDING TEXT 

 Aligning pictures is important if you want to have the 
text to be wrapped around them. 
 

 Follow these steps: 
 

1. Double-click the picture.  The picture property dialog 
box appears. 

 

2. Click the Appearance tab. 
 

3. Select Left or Right in the Wrapping Style area, to 
align the picture against the left or right margin and 
have the text wrap around it. 
 

4. Click OK. 
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PRACTICE #13 
1. In about.htm, insert a relevant picture where you 

typed the text about your institution and have the 
text wrap around it.  Select Left or Right (your 
choice). 
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MODIFYING THE DYNAMIC WEB 
TEMPLATE 
 If you generated a web site from an existing template, 

you can customize it to meet your needs. 
 

 Follow these steps: 

1. Double-click master.dwt in your site’s root folder to 
open it for editing. 
 

2. You can add, modify, and remove elements from it. 
 

3. Save the page to accept all changes. 
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PRACTICE #14 
1. In master.dwt, where it says Organization at the 

top, replace it by your organization’s name. 
 

2. Replace Organization Description with a brief 
description about your organization. 
 

3. To the left of your organization’s name at the top, 
insert a picture that will represent its logo.   
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MODIFYING THE CASCADING 
STYLE SHEETS 
 If you generated a web site from an existing template, you can 

customize it to meet your needs. 
 

 Follow these steps: 
1. Double-click master.dwt in your site’s root folder to open it for 

editing. 
 

2. On the Format menu, point to CSS Styles and then click 
Manage Style Sheet Links.  The Link Style Sheet dialog box 
appears. 
 

3. Remove the current style sheet being used. 
 

4. Click the Add button and navigate to the styles folder and select 
a different style. 
 

5. Click OK.  If you are satisfied with your style, save your work. 
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PRACTICE #15 
1. In master.dwt, change the use the style3.css.  

 

 

42 



MODIFYING THE CASCADING 
STYLE SHEETS II 
 When the template generate your website, it created 

several regions, the main five are: 
 #masthead: region that has the organization name and 

description at the top. 
 

 #container:  main canvas area where other regions are placed 
on. 

 #navigation:  region that contains the main navigation links. 
 

 #content:  region in which the designer can enter the main 
content for the webpage. 
 

 #footer:  region that is located at the bottom of the webpage.  
In many cases, you may also find navigation links here. 
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MODIFYING THE CASCADING 
STYLE SHEETS II 
 You can change the styles for each of these elements in your 

dwt file.  This will automatically be reflected in every page 
of your website. 
 

 Follow these steps: 
1. In the Manage Styles pane (bottom right), right-click the 

region that you want to modify its CSS style then click 
Modify Style.  The Modify Style Sheet dialog box appears. 
 

2. In the Category list, select the category that you wish to 
modify. 
 

3. Make the necessary modifications. 
 

4. Click OK.  If you are satisfied with your style, save your 
work. 
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PRACTICE #16 
1. In master.dwt, for the second #masthead, change the 

following: 
  Background 

 Background color: #C0C0C0 (0 is the number zero) 

 Background-image: select the image that you got as your logo. 

 Background-repeat: no-repeat 

 Background-position (x): left 

 Position 
 Height: 115 

 

2. For #masthead h1 
 Block 

 Text-Align: Right 
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PRACTICE #17 
1. For #masthead h3 

 Block 

 Left Padding: 100 px 
 

2. For #footer a:hover 

 Font 

 Check underline and overline boxes. 

3. For #footer a 

 Block 

 Check the none box. 
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INSERTING FLASH FILES 
 One benefit of building a Web site is adding Flash animations. 

 

 Follow these steps: 
1. Select the location on the web page where you want to insert the 

flash file. 
 

2. On the Insert menu, point to Media, and then click Flash 
Movie.  The select Media File dialog box opens. 
 

3. Browse to locate the file, select it, and then click Insert.  The file 
is visible on the page. 
 

4. Save your page.  In the Save Embedded Files dialog box, click 
Change Folder.  Select a folder in your website to put that file.  If 
the folder does not exist, create it. 

5. Click OK to save your page. 
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PRACTICE #18 
1. Replace the text that says Heading 2 with the word Welcome 

 

2. In the default.htm, delete the gibberish text. 
 

3. In the default.htm, insert the file called flash.swf below the 
text entered in step 1. 
 

4. Right-click flash.swf and click Flash SWF Properties.  
Change the following properties: 

 Width: 240 px 

 Height: 180 px 

 Name: FlashExample 

 No autoplay 

5. Type Flash Video below the flash.swf file. 
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INSERTING WMV FILES 
 You can also embed windows media video files in your web page. 

 

 Follow these steps: 
1. Select the location on the web page where you want to insert the 

flash file. 
 

2. On the Insert menu, point to Media, and then click Windows 
Media Player.  The select Media File dialog box opens. 
 

3. Browse to locate the file, select it, and then click Insert.  The file 
is visible on the page. 
 

4. Save your page.  In the Save Embedded Files dialog box, click 
Change Folder.  Select a folder in your website to put that file.  If 
the folder does not exist, create it. 
 

5. Click OK to save your page. 
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PRACTICE #19 
1. Below the Flash Movie with its caption, insert the file 

called Windows Media.wmv 
 

2. Right-click Windows Media.wmv and click 
ActiveX Control Properties.  Change the following 
properties: 

 Name: ExpressionMediaExample 

 Height: 180 

 Width: 240 

 No autostart 

3. Type Windows Media Video below the wmv file. 
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RUNNING CSS REPORTS 
 Use the Expression Web CSS reports to find out more about what styles are 

being used or not in your site.  It can detect three major problems: 
 Unused styles 
 Undefined classes 
 Mismatched case: class/id-based styles where the style rule selector uses a 

different case than the class/id attribute value. 
 

 Follow these steps: 
1. Open a web page. 

 

2. Click Tools->CSS Reports.  The CSS Reports dialog box appears. 
 

3. In the Check Where area, choose the option for which pages you want the 
report to check. 
 

4. In the Check For area, choose the type of errors you want the report to check 
your pages for. 
 

5. Click the Check button to run the report . 
 

6. Make use of the reporting tools to find and fix these errors. 
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PRACTICE #20 
1. Run the CSS report.  Pay attention to the line 

number that has the problem (if any errors are 
found) and remove them. 
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CREATING TABLES 
 Tables are useful for cordoning off individual pieces of data into 

cells.: 
 

 Expression Web has several methods.  This one is the easiest and 
fastest: 

1. Place the cursor in the page where you want the table to appear. 
 

2. Click the Insert Table button, on the common toolbar.  A grid of 
white boxes representing table rows and columns appears 
underneath the button. 
 

3. Click and drag our cursor on the grid until the number of 
highlighted boxes equals the number of rows and columns you 
want the table to have. 
 

4. Release the mouse button. 
 

 53 



PRACTICE #21 
1. In contact.htm, below phone number and fax 

number, create a 4 x 3 table. 

2. Enter the following information 
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Name Department Phone E-mail 

John 
Smith 

Information 
Technology 

x5899 smithj@xyz.com 

Mary 
Jefferson 

Human Resources x7144 jeffersonm@xyz.com 



CONVERTING EXISTING TEXT INTO A 
TABLE 
 If you already have text that you want to format into a data 

table, you can convert text that is separated with commas 
or another character into a table. 

 

 Follow these steps: 
1. Highlight the desired text. 

 

2. Click Table->Convert->Text to Table.  The Convert Text to 
Table dialog box appears. 
 

3. Select the option next to the text separator that you want 
Expression Web to recognize when it creates columns.  If the 
text separator is not a comma, select the Other option and then 
type the text separator character. 
 

4. Click OK. 
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INSERTING CELL PADDING AND CELL SPACING 
 Cell padding refers to adding space between content of 

table cells and their cell borders. 
 

 Cell spacing refers to the amount of space between cells. 
 

 Follow these steps: 
1. Right-click the table and click Table Properties. 

 

2. To enlarge the area between cell contents and their borders, in 
the Cell Padding text box, type the desired amount of padding 
in pixels. 
 

3. To add space between cells, in the Cell Spacing text box, type 
the desired amount of spacing in pixels separating the cells. 
 

4. Click OK. 
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ADDING BORDERS TO DATA TABLES 
 By default, Expression Web produces tables without visible borders 

(although they can be seeing in design view). 
 

 Tables have two borders 
 Cell border: surrounds individual cells 
 Table border: surrounds entire table 

 
 

 Follow these steps: 
1. If you want to add cell borders, select all the cells from the table, 

otherwise, skip to step 2. 
 

2. Right-click the table, and click Cell Properties (adding cell borders) or 
click Table Properties (adding table borders). 
 

3. To change the border color, from the Color list box, choose the desired 
color.  If you are doing table border go to step 4 otherwise, skip to step 5. 
 

4. If you prefer to put a single line between cells (rather than outline each 
individual cell with a box) select Collapse Table Border 
 

5. Click OK. 
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PRACTICE #22 
1. In contact.htm, set the table border to dark blue, 

size 1, and the cell border to green, size 1. 

 

2. Just before the table, type Other Contacts and make 
it header 3 
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TESTING YOUR WEB SITE 
 Before you publish your web site, you need to test if your web site 

complies with certain requirements standards. 
 

 The following is a check list that your web site must pass before being 
published on the WWW 
 Verifying Hyperlinks: See Slide 24 

 

 Run a CSS Report: See Slide 47 
 

 Run the Accessibility Checker: makes sure that it complies with 
accessibility guidelines so that visitors with impaired vision and 
other disabilities can use your site. 
 

 Run the Compatibility Checker: looks for any problems in the 
code. 
 

 Run other problem-oriented reports (Slow pages report and 
unlinked pages report) 
 

 Check for spelling errors 
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RUNNING THE ACCESSIBILITY CHECKER 
 When your site is accessible, it recognizes visitors with 

disabilities or may speak different languages. 
 

 The WWW Consortium (W3C) and the U.S. government 
have come up with the guidelines and they can be read at 
www.w3.org/TR/WAI-WEBCONTENT/  
 

 The Access Board, an agency of the U.S. federal 
government has also created accessibility standards 
specifically for web sites under Section 508 of the 
Rehabilitation Act, passed in 1988. 
 

 Both sets are supported by Expression Web and it then 
propose design changes based on what it finds. 
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RUNNING THE ACCESSIBILITY CHECKER 
 Follow these steps: 

1. With a web site open, click Accessibility Reports, in the Tools 
menu.  The Accessibility Checker dialog box appears. 
 

2. In the Check Where section, choose the radio button next to the 
group of pages that you want Expression Web to check.  You can 
check the entire site at once, or you can select specific pages. 
 

3. In the Check For section, choose the check boxes next to 
accessibility standards that you want to use (Suggestion: include 
all three). 
 

4. In the Show section, choose the check boxes next to the types of 
information that you want to appear in the report.  You can check 
for three types: errors, warnings and manual checklist. 
 The latter refers to potential red flags, but which you may have 

already handled correctly already (e.g. linking your page to an 
external style sheet) 

 

5. Click the Check button. 
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PRACTICE #23 
1. Verify the hyperlinks for the entire site. 

 

2. Generate a CSS Report to see if there are any 
problems with your external CSS files, and fix them if 
you can (if any). 
 

3. Run the Access Checker and fix any problems if you 
can (if any). 
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RUNNING THE COMPATIBILITY CHECKER 
 This tool is a useful tool for bringing an older site up to 

today’s web standards, because it can check for 
nonstandard ways of specifying formatting. 
 

 It can also check for missing or deprecated (outdated) 
tags. 
 

 Follow these steps: 
 

1. With a web site open, click Compatibility Reports, in the Tools 
menu.  The Compatibility Checker dialog box appears. 
 

2. In the Check Where section, choose the radio button next to the 
group of pages that you want Expression Web to check.  You can 
check the entire site at once, or you can select specific pages. 
 

3. In the Check HTML/XHTML Compatibility With list box, 
choose the version of the code rules you want to check your code 
against (Suggestion leave the default –XHTML Transitional) 
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RUNNING THE COMPATIBILITY CHECKER 
4. Leave the Check CSS Compatibility option set to CSS 2.1, unless 

you are sure you need to check your CSS code against an earlier 
version.  This only checks for internal CSS embeded in your web 
pages. 
 

5. Leave the Run Check Based On Doctype Declaration in Page 
If Available check box selected. 
 

6. Click the Check button.  This shows you every problem identified 
by page and line number, and a problem summary.  By double 
clicking on an item, it will take you to the code where the problem 
is located. 
 

 NOTE: Being able to fix problems here, require HTML 
knowledge. 
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RUNNING OTHER REPORTS 
 Using the Site View tab, you may click on: 

 Unlinked Files if you want to verify the existence of 
orphan pages. 

 

 Slow Pages if you want to verify the existence of pages that 
takes too long to load in the browser. 

 

 Click Tools->Spelling->Spelling if you want to 
proofread your pages. 
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PRACTICE #24 
1. Run compatibility checker with XHTML 1.0 

transitional as the Check HTML/XHTML 
Compatibility With option. 
 

2. Run the slow pages report, and unlinked pages 
report. 
 

3. Proofread your site. 
 

4. Re-save your work. 
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OPTIMIZE HTML CODE OF WEBSITE 

 This allows you to remove unnecessary code from your web 
pages, in order to keep your code clean and reduce the file size 
(affects load time). 

1. Go to Site->Publishing settings tab, then click the Publishing 
tab. Do this step only if you want the software to clean up your 
code. 
 

2. Select the option Optimize HTML during publishing. 
 

3. Click the Customize button. 
4. Choose the items that you want to remove from the page and then 

click OK button twice. 
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PUBLISHING YOUR WEB SITE 

 You need to have the right publishing address (most 
likely an ftp site) in order to publish your site. 
 

 Follow these steps: 
1. Make sure you have your web site open and an active Internet 

connection. 
 

2. In the Site menu, click Publishing. You may have to click the 
Add a publishing destination link.  The Connection Setting 
dialog box appears. 

3. In the Name area, type the name of the site. 
 

4. In the Connection Type area, select the option that corresponds 
to the web server host type that from the site that will serve as 
your website’s host (e.g. FTP) 
 

5. In the Location text box, type the internet address of the remote 
website that you want to use as host (e.g. ftp://afs1.njit.edu) 
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PUBLISHING YOUR WEB SITE 

6. In the Directory area, type the folder/directory on the server you 
are publishing the files to. 
 

7. In the Username area, under Credentials type your username. 
Type your password under Password. 
 

8. Click Add. If the information was entered correctly, you will be 
connected to the server.   
 

9. Once connected, click the View drop down (just below the Site 
View tab), choose either All Files or Changed Files to publish 
the corresponding files. 
 

10. Click the publish files to the destination site arrow.  Looks like 
a blue arrow pointing to the right. 
 

 NOTE: If there are web pages that you don’t want to publish, you 
can flag them by right-clicking them and clicking Exclude from 
Publishing.  These files will not be transferred to the web server. 
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